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Step-by-Step Training Outline for Designing with Accessibility in Mind:  
Adobe Acrobat  
June 19, 2007  
 
You will use this series of steps to determine whether your PDF’s are accessible.  
You can follow these steps no matter what the origin of the PDF document was.  
 
 
STEP 1: Determine the Origin of the PDF file: 
 

- What is the original file type?  
- A scanned document 
- Word Processing Document (Microsoft Word) 
- Desktop Publishing (Adobe InDesign or Microsoft Publisher) 
- A Form 

 
STEP 2: Decide the purpose of the PDF file: 
 

- What will the final PDF file be used for? 
1. Is it a document to be read? 
2. Is it an Interactive Form? 

 
STEP 3: Determine whether or not the PDF is Accessible:  
 

- Is this PDF Accessible? 
1. Determine whether or not the PDF is a Scanned Image. 

o Zoom in on the document and look for pixelation. 
o Search for text on the page.  
o Run Read Out Loud. (View > Read Out Loud) 

2. If you determine the document to be a scanned document, follow 
these steps.  If you determine that it is not skip to step 3.  

o If it is a scanned document, perform OCR (Optical Character 
Recognition) (Document > OCR Text Recognition > 
Recognize Text Using OCR) 

o When the Recognize Text window appears select all pages.   
o Under Settings select Formatted Text & Graphics for PDF 

Output Style 
o Verify the language (English) 
o Under Downsample Images select Lowest Downsampling 

(600 dpi) 
o Search for and Correct “Suspects”  (Document > OCR text 

Recognition > Find First OCR Suspect) 
o Proofread your document.  
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o Try searching for a word within the document to ensure that it 
is indeed a searchable text document at this point. (Edit > Find) 

3. Determine whether or not the PDF is tagged.  
o Select File > Properties. Click on the description tab. In the 

bottom left-hand corner you will see a field that says Tagged 
PDF: (if you see the word Yes, it is tagged; if you see the 
word No, it isn’t.) 

o You may also want to select View > Navigation Panels > Tags 
to determine if any tags exist.  

4. If the PDF is not tagged, you will need to tag it manually.  
o Select Advanced > Accessibility > Add Tags to Document.  
o Select Advanced  > Accessibility > TouchUp Reading Order.  
o Use the TouchUp Reading Order Tool to clean up the tags 

automatically created in the previous step.  
o Verify the reading order of the elements on each page.  
o Click the Show Order Panel button.  

- If necessary add alternate text to graphics or figures. (  
- Add descriptions to form fields.  
- Verify proper tagging.  

o To add the needed tags, for instance, (select the heading on the 
page with the TouchUp Reading Order Tool, and click the 
Heading 1 button in the TouchUp Reading Order Panel.) 

o If you were tagging an image, etc. you would select figure 
instead of Heading 1.  

.  
5. If the PDF is tagged, determine whether or not it was tagged properly.  

o Is the document structured correctly (is it in proper reading 
order?) 

- With the TouchUp Reading Order Panel open 
(Advanced > Accessibility > TouchUp Reading 
Order), click the Show Order button and review the 
order of the items on the page.  

- If something is in the wrong order you can click and 
drag it into the correct order via the order panel, or 
you can click on the Content Tab and change the reading 
order within the document window.   

- Remember, reading order is not demonstrated by the 
location and alignment of the objects on the page. An 
object’s order is demonstrated by the small number 
located in the upper left-hand box of the object in the 
document window.   
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- The number in that box is what you need to refer to when 
determining whether or not the page is in logical reading 
order.  

o Has alternate text been added to all necessary graphics and 
figures? 

- To add alternate text to an image, open the TouchUp 
Reading Order Panel as discussed before.   

- Right-click on one of the objects that you need to add 
alternate text to. 

- Select Edit Alternate Text. 
- Add or edit the alternate text in the field provided.  
- Click Ok.  
- Remember, it is only necessary to provide information for 

those items that are of importance.  
6. If the document contains forms, have descriptions been added to the 

form fields? 
o To determine whether or not there are form fields present in 

your document, select Forms > Run Form Field Recognition.  
o If there are no form fields present, but you have decided this 

document is indeed supposed to contain form fields you will 
need to add them manually. 

o Select Tools > Forms > Show Forms Toolbar 
o If there are already form fields present, check the following:  

- Ensure that there are Labels and Descriptions in the tool 
tip fields (Tools > Forms > Edit Layout) 

- Set and test the tab order of the form fields. (You will 
need to click on the hand icon in the Acrobat toolbar to 
test the tab order.) 

 
Try tabbing through your form using the following 
suggestions:  
 
• Press your Tab key to move focus to the next field 
• Press Shift+Tab to move focus to the previous field  
• Press the Spacebar to select options 
• Press the Arrow keys to select radio button options 
or list items. 

o Add your first tag by clicking and dragging a box over the field 
area.  

o Add tags to your document after creating your form fields.  
7. Run the Adobe Acrobat Accessibility checker. (Advanced > 

Accessibilty > Full Check) (Run it for both Adobe Acrobat and 
Section 508 compliance.) 
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8. Fix any errors that the checker finds by repeating the steps discussed 
above. 

9. Continue to run the checker and fix errors until the checker appears to 
find no errors.  

 
Practice:  
 
Word Document:  
 
Suggestions:  
 

- When possible, start with a Word document that has been designed with 
Accessibility in mind.  

 
1. You will need to download and install the 2007 Microsoft Office Add-in: 

Microsoft Save as PDF or XPS add-in. It is located at: 
http://www.microsoft.com/downloads/details.aspx?FamilyId=4D951911-
3E7E-4AE6-B059-A2E79ED87041&displaylang=en (For the purposes of 
this workshop this add-in has already been installed.  Please do not 
download and install it again.) 

 
2. Open the Word Document that we applied accessible design techniques 

to in the previous hour. If you did not join us previously you will want to 
open, (wordpractice.docx) 

 
3. Click on the Office button > Save As > PDF or XPS.  

 
4. When the Publish as PDF or XPS dialog box appears: 

 
o Enter a file name in the File name: field.  
o Make sure that PDF (*.pdf) is chosen in the Save as type drop-

down menu.  
o Click on the Options button:  

 page range should be set to All,   
 publish what should be set to document,  
 Create bookmarks using: Headings should be checked 
 Document Structure tags for accessibility should be 

checked.  (This is the element that will allow the hierarchical 
structure that was set previously in Microsoft Office to be 
maintained.)  

o Click Ok.  
 

http://www.microsoft.com/downloads/details.aspx?FamilyId=4D951911-3E7E-4AE6-B059-A2E79ED87041&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=4D951911-3E7E-4AE6-B059-A2E79ED87041&displaylang=en
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PDF tags are comparable to HTML elements. Tags are required in order for 
screen readers and other assistive devices to convey the document structure and 
content. Acrobat’s reflow feature, discussed previously calls on tags in order to 
redraw the PDF page to fit existing window widths while keeping content within a 
single page. Acrobat’s Read Out Loud Feature uses tags to determine the 
reading order of the page.  
 
Tags do not affect the visual appearance of your document.  Although you may 
not be able to physically see the tags, you can follow the following steps to 
determine whether or not tags exist.  
 

5. To see if your document has been tagged, choose File > Properties > 
Description.  If you see the word Yes next to Tagged PDF at the bottom 
of the properties window then you have a tagged document.  If you see 
the word No you do not have a tagged document.  

 
6. Note: Using the File > Print to PDF will not yield the correct type of 

tagging necessary for an accessible document.  Make sure that you 
always use the add-in discussed previously to create your tagged PDF.  
There will of course be times that you end-up with an untagged, or 
inappropriately tagged document dependent upon the point of origin for 
that document.  You will learn how to add your own tags in a future 
section.  

 
7. Check the overall accessibility of your document by choosing Advanced > 

Accessibility > Full Check.  
 

8. When the Accessibility Full Check window appears: 
 

o Under Report and Comment Options: 
 Create Accessibility Report 
 Include repair hints in Accessibility Report should be 

selected.  
o Under Page Range:  

 All pages in document should be selected.  
o Under Checking Options Name, choose: 

 Adobe PDF (run that report) 
 Section 508 Web-based intranet and internet information 

and applications (1194.22) (run that report) 
o Click Select All to include all possible options in the report. 
o Click the Start Checking button.  
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o After running the Adobe PDF check the report should come back 
clean with no errors. (This is due to the hard work you did to set 
your Microsoft Word document up as an accessible document!)  

o Repeat the steps to run the Section 508 accessibility report.  
o The Section 508 will return 4 errors.  Notice that the detailed 

reports gives you information on how to correct the problems.  We 
will work on correcting this now.  

 
9. Correcting Accessibility Errors (Tables) 

 
Note: Verifying and Repairing Tables is one of the most time consuming 
processes you will do when making a PDF document accessible.  
 

o Click on the detailed report link to the left of your screen.  
o Select View > Page Display > Single Page (We want to ensure 

that this is chosen because we are going to be using the TouchUp 
Reading Order Tool.  Changes made with this tool cannot be 
undone and choices made with this tool can affect other pages 
if this is not done first!) 

o You will notice that the error has to do with the structure of the 
document and the fact that table elements had no TH tags.  

 Click on the first instance of “Table contains no Table 
Headers.” 

 You will be taken to the page where the problem resides.  
 You will notice that the problem has to do with the fact that 

when the word document was created the images appear to 
have been laid out in tables.   

 Choose Advanced > Accessibility > TouchUp Reading 
Order.   

 You will now see that there is a Table showing in the lower 
right-hand side of the window.  This is the result of the fact 
that tables were used to align the images in the original word 
document.  This is not recommended when designing for 
accessibility, but it can be corrected now.  

 Click the Show Order Panel button.  
 Click on the Order Tab.  
 Page 7 should be expanded. If not click the expansion 

button to expand it now.  
 Notice that the table has the number three in the upper-left 

hand corner in the document window.  
 Click on item 3 in the Order window.  
 Press Delete on your keyboard to omit the table.  
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 Notice at the top of the page there is also an extra object 
labeled 1. It appears to be just a blank spacer.  Select this 
object (1) in the Order window.  Press Delete on your 
keyboard to omit it. 

 Notice in the bottom left hand corner of your page there is a 
blank spacer labeled 2.  Select object (2) in the order 
window and press your delete key to remove it.  

 Look over the page.  You should now see that all of the 
elements on the page follow the correct reading order, no 
tables exist, and no blank spacers exist.  

 Save your document. (File > Save) 
 Run the Accessibility checker again.  Notice that there are 

still 3 errors remaining.  
 Click on the first instance of “Table contains no Table 

Headers.” 
 You will be taken to the page where the problem resides. It 

is page 8.  “COEHS Holiday Party Highlights.” 
 You will notice that the problem has to do with the fact that 

when the word document was created tables were used to 
align the images.  

 Click the Show Order Panel button.  
 Click on the Order Tab.  
 Page 8 should be expanded. If not, click the expansion 

button to expand it now.  
 Notice that the table in question has the number 3 in the 

upper-left hand corner in the document window.  
 Click on object 3 in the Order window.  
 Press Delete on your keyboard to omit the table.  
 Notice at the top of the page there is also an extra object 

labeled 1. It appears to be just a blank spacer.  Select this 
object (1) in the Order window.  Press Delete on your 
keyboard to omit it. 

 Notice in the bottom left hand corner of your page there is a 
blank spacer labeled 2.  Select object (2) in the order 
window and press your delete key to remove it.  

 Look over the page.  You should now see that all of the 
elements on the page follow the correct reading order, no 
tables exist, and no blank spacers exist.  

 Save your document.  
 Run the Accessibility checker again.  Notice that there are 

still 3 errors remaining.  
 Repeat this process for page 9 of the document.  
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Fixing Alternate Text:  
 

- Notice that some of the alternate text in the document provided may be 
lacking description.  You can add new alternate text or edit existing 
alternate text in the TouchUp Reading Order toolbar as well.  

- Navigate to one of your pages that contains pictures.  (Page 8 might be a 
good starting point.) 

- Select Advanced > Accessibility > TouchUp Reading Order to turn on 
the TouchUp Reading Order tool. 

- When the Touch Up Reading Order window appears right-click on one 
of the images in the document window.   

- Choose Edit Alternate Text from the menu.  
- When the Alternate Text window appears, add the text for the image.   
- Click OK.   
- Continue to work through this process until you have ensured that every 

figure in your document contains appropriate alternative text description.  
 
Check the document for correct reading order throughout:  
 

- Notice on page 11, the reading order isn’t exactly right.  You can use 
the TouchUp Reading tool that we have already talked about to fix 
this problem.   

- Navigate to page 11.  
- Notice that first of all the header is submerged inside of the page 

content.  Secondly, reading order 1 flows over into the second 
column.  This latter problem isn’t such a concern but it is correctable.  

- First, to correct the heading.   
- Choose Advanced > Accessiblity > TouchUp Reading Order.  
- When the TouchUp Reading Order toolbox appears, click the Show 

Order Panel button.  
- Choose Clear Page Structure.  
- Select the TouchUp Reading Order Tool.  
- Draw a box around the text “Working with Columns.”  
- Click Heading 1.  
- With the TouchUp Reading Order Tool.  
- Draw a box around all of the text in Column 1.  
- Click Text.  
- Draw a box around all of the text in Column 2.  
- Click Text. 
- You will now see that the reading order of the page is set to 1, 2, 3.  This 

is the correct reading order.  
- You could go and check all pages of the document and change them at 

this time but for the sake of this workshop we will not.   
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- Run the Accessibility checker.  At this point your document should pass 
if you have made all of the necessary corrections.  With the 508 checker 
you will notice that some remarks remain.  That is because Adobe Acrobat 
can not test for things such as color.  This requires that a user manually 
tests it.  

 
Save the document as HTML:  
 

- In order to make your document ultimately accessible you are going to 
want to save as HTML format.  

- Choose File > Save As  
- In the File name field enter a name for your file.  
- In the Save As Type drop-down menu, choose HTML 4.01 with CSS 1.0 

(*.html, *.html). 
 
 
Scanned Document:  
 

1. Open the file labeled (scan1practice.pdf) 
2. Zoom in to determine that it is indeed a scanned document. (Use the 

magnifying glass tool or choose (View > Zoom > Zoom To . . .) 
3. It is best to start with a document that has been scanned as black and 

white at 300 pixels for the conversion.  
4. Perform OCR. (Document > OCR Text Recognition > Recognize Text 

Using OCR.) 
5. Select All Pages.  
6. Select Edit and then set the following:  

a. Primary OCR Language: English 
b. PDF Output Style: Formatted Text and Graphics 
c. Downsample: Lowest (600 dpi) 
d. Select OK.  

7. Look for OCR Suspects. (Document > OCR Text Recognition > Find All 
OCR Suspects.) 

8. Search for a word in the document to ensure that this is indeed searchable 
text.  (Edit > Find)  

9. In a real situation you would want to proofread your document.  
10. Determine whether or not the PDF is tagged. (File > Properties > 

Description) 
11. You may also want to choose (View > Navigation Panels > Tags) to 

determine if there really are any tags. 
12. Tag the PDF Manually.  

- Select (Advanced > Accessibility > Add Tags to Document.) 
- Select page 1 of your document.  
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- Use the TouchUp Reading Order Tool to clean up the tags 
automatically created in the previous step.  (Advanced > 
Accessibility > TouchUp Reading Order.) 

- Select the Show Order Panel button.  
- At this point it is not exactly structured the way we want it to be.  

We want to set the headings off from the rest of the page, and 
remove the elements that have impact on the reader.  

- Return to page 1 if you aren’t already there.  
- Select (View > Page Display > Single Page.)  
- In the TouchUp Reading Order panel, select Clear Page 

Structure. 
- The first thing that we are going to tag is the Heading for the page.  

With the TouchUp Reading Order Tool, draw a  rectangle 
around the text “Summary of Article”, select Heading 1.  

- With the TouchUp Reading Order Tool selected, draw a 
rectangle around the main text of the document, select Text.  

- Select the Name, Course Number, and Assignment Name at the 
top of the page. Select Background. (Selecting background allows 
you to remove non-essential information from the document 
structure, allowing screen reader to skip over it.) 

- Move on to page two. We will repeat the same process with minor 
changes.  

-  Draw a box around the orphaned text at the top of the page 
using the TouchUp Reading Order tool. Select Text.  

- With the TouchUp Reading Order tool, draw a rectangle around 
the text Critique of Article. Select Heading 1.  

- With the exception of the page number at the bottom of the page, 
the remainder of the text is already bound by a box labeled 3.   

- Draw a box around the page number at the bottom of the page. 
Select Background.  

- Continue to follow the same process to tag the rest of your 
document.  

- Once you have tagged all of the text. Run the Accessibility 
Checker. (Remember to run both the PDF and 508 checkers.) 

- You will likely have some errors. 
- First, you need to set a language specification for the document. 

Select (File > Properties > Advanced) Choose English from the 
language drop-down box.  

- Run the accessibility checker for both PDF and 508 again.  With the 
508 report there will always be an error returned because the user 
actually has to check manually for color.  
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Save the document as HTML:  
 

- In order to make your document ultimately accessible you are going to 
want to save it as HTML format.  

- Choose File > Save As  
- In the File name field enter a name for your file.  
- In the Save As Type drop-down menu, choose HTML 4.01 with CSS 1.0 

(*.html, *.html). 
 
 
Form:  
 

1. Open the file form-practice.pdf 
2. Determine if this is a scanned image.  If it is you will need to perform 

OCR.  If it is not you won’t.  This is not a scanned image.  
3. This is meant to be an interactive form that the user can fill out.  
4. Is the document tagged? (File > Properties > Description) No.  
5. Determine whether or not form fields currently exist. (Forms > Run Form 

Field Recognition) 
6. For this document, form fields already exist.  
7. Determine whether or not Labels and Descriptions have been added to 

the form fields.  
8. If there were no labels or descriptions, add Labels and Descriptions to 

the Form Fields. (This will allow the screen reader to notify visually 
impaired individuals of the type of information they must provide in the 
form field.) 

9. Select (Tools > Forms > Edit Layout) Double-click on the first form 
field “District.” Ensure that there is a description in the tool tip field.  You 
should see that there is indeed. Screen readers identify and read 
descriptions placed in the tool tip field to the users.  

10. You will notice that all of the form fields on page one appear to be 
properly labeled and include tool tip descriptions. 

11.  However, when you get to page two you will see that there are some 
problems.  First of all, there are some form fields missing.  Secondly, not 
all of the existing fields are labeled correctly.  

12. Let’s correct the existing form fields first.  
13. If you have not already, choose (Tools > Forms > Edit Layout). 

Double-click the first form field. (It is currently labeled feet.) 
14. Notice that the current tool tip description just says (feet).  This is not 

enough description for people to understand what is needed here. Enter 
the following text into the tool tip description for this box: “Distance to 
nearest residence in feet.” 

15. Continue down the page to correct the form fields for:  
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a. Feet 2 – “Distance to nearest business in feet” 
b. Is a rain cap… - “Height of stack in feet” (change the name to 

Feet) 
c. Yes – “Stack inside diameter in inches” (change the name to 

Inches) 
d. Date – “Date of Signature” 

16. Next, we will be adding radio buttons for the Yes/No answers in the 
document.  

17. With the Radio button selected, double-click on the document to 
create a radio button.  

18. In the Name box type “yes” in the tool tip type “ Is raincap present 
on exhaust stack (yes or no)” 

19. Click on the Options tab.  Make sure Export Value is set to Yes. Select 
Check from the Button Style drop down menu.  Close the form dialog 
box.  

20. Resize and position the form field as necessary by pulling the handles 
and moving it with the arrow keys on your keyboard.  

21. Create a Radio button for the no selection.  
22. In the tool tip type “Is raincap present on exhaust stack (yes or no)” 
23. Click on the Options tab. Make sure the Export Value is set to No.  

Select Check from the Button Style drop down menu. Close the form 
dialog box. Continue to create radio buttons for the additional fields.  

24. To make life easier on yourself you can experiment with duplicating and 
placing multiple fields at once.  Shift-click to select the radio buttons 
you made previously. (Select Forms > Edit Fields > Duplicate)  You 
will have to move the radio buttons into the desired position. 

25. You will now need to set and test the tab order for the form.  
26. If there appear to be problems with the tab order you will need to fix that.  

(Choose Tools > Forms > Edit Layout.)  
27. Choose (Forms > Edit Fields > Set Tab Order).  
28. Attempt to let Acrobat automatically determine the order for you.  
29. Test again.  
30. If you still see problems, choose (Forms > Edit Fields > Set Tab Order) 

and do not allow acrobat to set the tab order automatically.  
31. When the form fields appear with boxes that contain numbers in the 

upper left-hand corner.  Move through the document and click in the 
boxes in the order you want them to be tabbed through.  

32. Test the tab order again by using the hand icon from the toolbar.  
Remember, you will only be able to tab through those fields that have 
been created.  

33. Add tags to your document. Choose (Advanced > Accessibility > Add 
Tags to Document.)  
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34. Open the Touch up Reading tool. (Advanced > Accessibility > Touch 
Up Reading Tool.) Look through the tagging of the document.  Make 
any necessary changes as we did in the previous documents.) 

35. Add alternate, text, change reading order if necessary, etc.  
36. Run the Accessibility Checker (Advanced > Accessibility > Full Check)  

At this point your document should pass if you have made all of the 
necessary corrections.  With the 508 checker you will notice that some 
remarks remain.  That is because Adobe Acrobat can not test for things 
such as color.  This requires that a user manually tests it. 

 
 
Desktop Publishing Document from Adobe InDesign:  

 
1. Make sure headings, text, and images are not contained in the same 

frame 
2. Choose Window > Tags to display the tags palette. 
3. To determine if your InDesign document is structured, select View > 

Structure > Show Structure, or Alt + Ctrl + 1, to display the InDesign 
structure pane. 

o If your InDesign document is not tagged, the structure pane will be 
empty except for the root. 

4. Choose Add Untagged Items from the Structure Menu Pane Menu 
o This will cause a structure tree to appear in the structure pane and 

color coded tags to appear in the tags palette.  These colors 
correspond to the colored items on the document view. 

5. Review the tags and make sure they are correct.  To “re-tag” individual 
elements click on the correct tag in the tags palette and drag it to the 
element you want to “re-tag”. 

6.  Select the Figure element in the Structure pane, and then choose New 
Attribute from the Structure pane menu.      

7. In the Name field of the New Attibute Dialog box, type Alt (this feature 
is case-sensitive). For Value field of the New Attribute Dialog, type the 
text that describes the image 

8. Once the Adobe InDesign File has been set up you will be ready to 
generate an accessible PDF.  Select File > Export from the InDesign 
menu or type Control +E.  Make sure Adobe PDF is selected as the Save 
as type.    

9. Choose Save and the Export Adobe PDF dialog will appear Be sure that 
the check box labeled Create Tagged PDF is checked. Also, having 
Bookmarks and Hyperlinks checked also contributes to the accessibility 
of the resulting PDF document. 
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10. If the PDF didn’t open automatically, open the newly created PDF now. 
 

11. Choose Advanced > Accessibility > TouchUp Reading Order select the 
Show Order Panel button 

12. Look over the PDF and make sure that everything is in a logical reading 
order. 

13. If something is out of order, you can manually re-order it by clicking the 
Order Tab in the Show Order Panel.  Click and drag the items to their 
correct location or clear the page structure and add the tags manually. 

14. Accessibility Checker (Advanced > Accessibility > Full Check)  At this 
point your document should pass if you have made all of the necessary 
corrections.  With the 508 checker you will notice that some remarks 
remain.  That is because Adobe Acrobat can not test for things such as 
color.  This requires that a user manually tests it. 

 
 
Online Booklet 
 
http://www.adobe.com/enterprise/accessibility/training.html  
http://www.adobe.com/enterprise/accessibility/acrobat.html  
http://www.adobe.com/enterprise/accessibility/pdfs/acro6_pg_ue.pdf 
 

http://www.adobe.com/enterprise/accessibility/training.html
http://www.adobe.com/enterprise/accessibility/acrobat.html
http://www.adobe.com/enterprise/accessibility/pdfs/acro6_pg_ue.pdf

